# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\$#[\w\s]{0,100})\s+(?=[\w\s]*#)//gm;t' <<< "This is my variable A $#testpattern 1# and this is variable B $#testpattern 2 with multiple blanks#
"