re = /(?<=\$#[\w\s]{0,100})\s+(?=[\w\s]*#)/m
str = 'This is my variable A $#testpattern 1# and this is variable B $#testpattern 2 with multiple blanks#
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result