import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\$#[\\w\\s]{0,100})\\s+(?=[\\w\\s]*#)";
final String string = "This is my variable A $#testpattern 1# and this is variable B $#testpattern 2 with multiple blanks#\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}