#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\$#[\w\s]{0,100})\s+(?=[\w\s]*#)"
Local $sString = "This is my variable A $#testpattern 1# and this is variable B $#testpattern 2 with multiple blanks#" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)