using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\$#[\w\s]{0,100})\s+(?=[\w\s]*#)";
string substitution = @"";
string input = @"This is my variable A $#testpattern 1# and this is variable B $#testpattern 2 with multiple blanks#
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}