package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mxs)(?(DEFINE)
(?P<date>\d{2}/\d{2}/\d{2},\ \d{2}:\d{2})
)
^
(?&date)
(?:(?!^(?&date)).)+`)
var str = `27/08/15, 15:45 - text
continue text
continue text 2
27/08/15, 16:10 - new text
new text 2
new text 3
27/08/15, 19:55 - more text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}