// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mxs)(?(DEFINE)
(?P<date>\d{2}/\d{2}/\d{2},\ \d{2}:\d{2})
)
^
(?&date)
(?:(?!^(?&date)).)+").unwrap();
let string = "27/08/15, 15:45 - text
continue text
continue text 2
27/08/15, 16:10 - new text
new text 2
new text 3
27/08/15, 19:55 - more text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}