re = /(?(DEFINE)
(?P<date>\d{2}\/\d{2}\/\d{2},\ \d{2}:\d{2})
)
^
(?&date)
(?:(?!^(?&date)).)+/mx
str = '27/08/15, 15:45 - text
continue text
continue text 2
27/08/15, 16:10 - new text
new text 2
new text 3
27/08/15, 19:55 - more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end