#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^AB[1-9][AB]-[^:]+:[A-Z][0-9]{2}$"
Local $sString = "AB8B-ANYLETTERS:H12" & @CRLF & _
"AB3B-ANYTHINGCANGOHERE:A77" & @CRLF & _
"AB3B-ANYTHINGCANGOHERE:A00" & @CRLF & _
"AB3B-ANYTHINGCANGOHERE:A11" & @CRLF & _
"AB3B-ANYTHINGCANGOHERE:A99" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")