$re = '/^AB[1-9][AB]-[^:]+:[A-Z][0-9]{2}$/m';
$str = 'AB8B-ANYLETTERS:H12
AB3B-ANYTHINGCANGOHERE:A77
AB3B-ANYTHINGCANGOHERE:A00
AB3B-ANYTHINGCANGOHERE:A11
AB3B-ANYTHINGCANGOHERE:A99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);