re = /^AB[1-9][AB]-[^:]+:[A-Z][0-9]{2}$/m
str = 'AB8B-ANYLETTERS:H12
AB3B-ANYTHINGCANGOHERE:A77
AB3B-ANYTHINGCANGOHERE:A00
AB3B-ANYTHINGCANGOHERE:A11
AB3B-ANYTHINGCANGOHERE:A99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end