const regex = /^AB[1-9][AB]-[^:]+:[A-Z][0-9]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^AB[1-9][AB]-[^:]+:[A-Z][0-9]{2}$', 'gm')
const str = `AB8B-ANYLETTERS:H12
AB3B-ANYTHINGCANGOHERE:A77
AB3B-ANYTHINGCANGOHERE:A00
AB3B-ANYTHINGCANGOHERE:A11
AB3B-ANYTHINGCANGOHERE:A99
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}