using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^AB[1-9][AB]-[^:]+:[A-Z][0-9]{2}$";
string input = @"AB8B-ANYLETTERS:H12
AB3B-ANYTHINGCANGOHERE:A77
AB3B-ANYTHINGCANGOHERE:A00
AB3B-ANYTHINGCANGOHERE:A11
AB3B-ANYTHINGCANGOHERE:A99
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}