using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^SQF-S25(C9-960GDCGE|V4-1TDSDC|V4-1T-SBC|Z8-960GDSCC)$";
string input = @"SQF-S25C9-960GDCGE
SQF-S25V4-1TDSDC
SQF-S25V4-1T-SBC
SQF-S25V4-240GDSCE
SQF-S25Z8-960GDSCC
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}