package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^SQF-S25(C9-960GDCGE|V4-1TDSDC|V4-1T-SBC|Z8-960GDSCC)$`)
var str = `SQF-S25C9-960GDCGE
SQF-S25V4-1TDSDC
SQF-S25V4-1T-SBC
SQF-S25V4-240GDSCE
SQF-S25Z8-960GDSCC
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}