// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^SQF-S25(C9-960GDCGE|V4-1TDSDC|V4-1T-SBC|Z8-960GDSCC)$").unwrap();
let string = "SQF-S25C9-960GDCGE
SQF-S25V4-1TDSDC
SQF-S25V4-1T-SBC
SQF-S25V4-240GDSCE
SQF-S25Z8-960GDSCC
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}