re = /^SQF-S25(C9-960GDCGE|V4-1TDSDC|V4-1T-SBC|Z8-960GDSCC)$/m
str = 'SQF-S25C9-960GDCGE
SQF-S25V4-1TDSDC
SQF-S25V4-1T-SBC
SQF-S25V4-240GDSCE
SQF-S25Z8-960GDSCC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end