import Foundation
let pattern = #"^SQF-S25(C9-960GDCGE|V4-1TDSDC|V4-1T-SBC|Z8-960GDSCC)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SQF-S25C9-960GDCGE
SQF-S25V4-1TDSDC
SQF-S25V4-1T-SBC
SQF-S25V4-240GDSCE
SQF-S25Z8-960GDSCC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)