using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]{5,})(\d{4,})|(\d{4,})([a-z]{5,})";
string input = @"ffffasfsaf242343242
2vv4fj222
555553jjjjjj
fdsfafadsfdf
234234324232
4444fasdfasf
3j3j3j3j3j3
11111jjjjjnnn
ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}