package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]{5,})(\d{4,})|(\d{4,})([a-z]{5,})`)
var str = `ffffasfsaf242343242
2vv4fj222
555553jjjjjj
fdsfafadsfdf
234234324232
4444fasdfasf
3j3j3j3j3j3
11111jjjjjnnn
ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}