$re = '/([a-z]{5,})(\d{4,})|(\d{4,})([a-z]{5,})/m';
$str = 'ffffasfsaf242343242
2vv4fj222
555553jjjjjj
fdsfafadsfdf
234234324232
4444fasdfasf
3j3j3j3j3j3
11111jjjjjnnn
ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);