# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-z]{5,})(\d{4,})|(\d{4,})([a-z]{5,})"
test_str = ("ffffasfsaf242343242\n"
"2vv4fj222\n"
"555553jjjjjj\n"
"fdsfafadsfdf\n"
"234234324232\n"
"4444fasdfasf\n"
"3j3j3j3j3j3\n"
"11111jjjjjnnn\n"
"ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.