package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^|.+)_-`)
var str = `The.Last.of.Us.S01E05.MULTi.1080p.HMAX.WEB-DL.DDP5.1.Atmos.H.264-PSiG`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}