import Foundation
let pattern = #"(^|.+)_-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"The.Last.of.Us.S01E05.MULTi.1080p.HMAX.WEB-DL.DDP5.1.Atmos.H.264-PSiG"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}