$re = '/(^|.+)_-/i';
$str = 'The.Last.of.Us.S01E05.MULTi.1080p.HMAX.WEB-DL.DDP5.1.Atmos.H.264-PSiG';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);