using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[([{|]*-?(\d*\.\d+|\d+\.?|\.)([)\]}|]*[-+*×/÷^%][([{|]*-?(\d*\.\d+|\d+\.?|\.))*[)\]}|]*$";
string input = @"{ + 1+ [+2.31*|2345- 6789.012| / 8 *(.+2)^6 -- 78.6]* -.84} +1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}