re = /^[([{|]*-?(\d*\.\d+|\d+\.?|\.)([)\]}|]*[-+*×\/÷^%][([{|]*-?(\d*\.\d+|\d+\.?|\.))*[)\]}|]*$/
str = '{ + 1+ [+2.31*|2345- 6789.012| / 8 *(.+2)^6 -- 78.6]* -.84} +1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end