package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[([{|]*-?(\d*\.\d+|\d+\.?|\.)([)\]}|]*[-+*×/÷^%][([{|]*-?(\d*\.\d+|\d+\.?|\.))*[)\]}|]*$`)
var str = `{ + 1+ [+2.31*|2345- 6789.012| / 8 *(.+2)^6 -- 78.6]* -.84} +1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}