import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[([\\{|]*-?(\\d*\\.\\d+|\\d+\\.?|\\.)([)\\]\\}|]*[-+*×/÷^%][([\\{|]*-?(\\d*\\.\\d+|\\d+\\.?|\\.))*[)\\]\\}|]*$";
final String string = "{ + 1+ [+2.31*|2345- 6789.012| / 8 *(.+2)^6 -- 78.6]* -.84} +1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}