import Foundation
let pattern = #"^[([{|]*-?(\d*\.\d+|\d+\.?|\.)([)\]}|]*[-+*×/÷^%][([{|]*-?(\d*\.\d+|\d+\.?|\.))*[)\]}|]*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{ + 1+ [+2.31*|2345- 6789.012| / 8 *(.+2)^6 -- 78.6]* -.84} +1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}