#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[a-zA-Z]*0*|[a-zA-Z]+"
Local $sString = "U01234BC" & @CRLF & _
"001111" & @CRLF & _
"1Z4R00567U" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)