const regex = new RegExp('^[a-zA-Z]*0*|[a-zA-Z]+', 'gm')
const str = `U01234BC
001111
1Z4R00567U
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);