$re = '/^[a-zA-Z]*0*|[a-zA-Z]+/m';
$str = 'U01234BC
001111
1Z4R00567U
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;