use strict;
my $str = 'U01234BC
001111
1Z4R00567U
';
my $regex = qr/^[a-zA-Z]*0*|[a-zA-Z]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";