#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}.\d{3}-\d{2}:\d{2})$"
Local $sString = "2023-06-30T21:28:39.779-03:00" & @CRLF & _
"2023-06-30T21:28:39.779-03:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")