using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}.\d{3}-\d{2}:\d{2})$";
string input = @"2023-06-30T21:28:39.779-03:00
2023-06-30T21:28:39.779-03:00";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}