import re
regex = re.compile(r"^(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}.\d{3}-\d{2}:\d{2})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2023-06-30T21:28:39.779-03:00\n"
"2023-06-30T21:28:39.779-03:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")