package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}.\d{3}-\d{2}:\d{2})$`)
var str = `2023-06-30T21:28:39.779-03:00
2023-06-30T21:28:39.779-03:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}