re = /^(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2}.\d{3}-\d{2}:\d{2})$/mi
str = '2023-06-30T21:28:39.779-03:00
2023-06-30T21:28:39.779-03:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end