using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^5[1-5]\d{14}$";
string input = @"5245123412347894
5645123412347894
5241123412347894
6245123412347894
12451234123478AA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}