$re = '/^5[1-5]\d{14}$/m';
$str = '5245123412347894
5645123412347894
5241123412347894
6245123412347894
12451234123478AA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);