re = /^5[1-5]\d{14}$/m
str = '5245123412347894
5645123412347894
5241123412347894
6245123412347894
12451234123478AA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end