package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^5[1-5]\d{14}$`)
var str = `5245123412347894
5645123412347894
5241123412347894
6245123412347894
12451234123478AA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}