package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((G[ou]{2,}d{1,})|Great|Awesome) ((Morning|Afternoon|Evening|Night)\/?){2,} (ya|ever|all)`)
var str = `Oh! Good morning waffle!
Nevah!
Not for another 12 ish Horus at least
perfect
Ye
Ooof sorry
O
O
ÙwÚ
*I will always test loopholes uwu*
Could try
UwU
could be better could be worse
ok so its random good
Good Evening/Afternoon/Morning/Night yall
Good Night/Evening/Afternoon/Morning ya
Ty
Hours*
hope u two goodnight
ooo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}