import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((G[ou]{2,}d{1,})|Great|Awesome) ((Morning|Afternoon|Evening|Night)\\/?){2,} (ya|ever|all)";
final String string = "Oh! Good morning waffle!\n"
+ "Nevah!\n"
+ "Not for another 12 ish Horus at least\n"
+ "perfect\n"
+ "Ye\n"
+ "Ooof sorry\n"
+ "O\n"
+ "O\n"
+ "ÙwÚ\n"
+ "*I will always test loopholes uwu*\n"
+ "Could try\n"
+ "UwU\n"
+ "could be better could be worse\n"
+ "ok so its random good\n"
+ "Good Evening/Afternoon/Morning/Night yall\n"
+ "Good Night/Evening/Afternoon/Morning ya\n"
+ "Ty\n"
+ "Hours*\n"
+ "hope u two goodnight\n"
+ "ooo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}