const regex = /((G[ou]{2,}d{1,})|Great|Awesome) ((Morning|Afternoon|Evening|Night)\/?){2,} (ya|ever|all)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((G[ou]{2,}d{1,})|Great|Awesome) ((Morning|Afternoon|Evening|Night)\\\/?){2,} (ya|ever|all)', 'gmi')
const str = `Oh! Good morning waffle!
Nevah!
Not for another 12 ish Horus at least
perfect
Ye
Ooof sorry
O
O
ÙwÚ
*I will always test loopholes uwu*
Could try
UwU
could be better could be worse
ok so its random good
Good Evening/Afternoon/Morning/Night yall
Good Night/Evening/Afternoon/Morning ya
Ty
Hours*
hope u two goodnight
ooo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}