package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[CDATA\[(.*?)\]\]`)
var str = `<surveyls_title><![CDATA[J.3200-1118 - Project Title]]></surveyls_title>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}