re = /\[CDATA\[(.*?)\]\]/m
str = '<surveyls_title><![CDATA[J.3200-1118 - Project Title]]></surveyls_title>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end