const regex = new RegExp('\\[CDATA\\[(.*?)\\]\\]', 'gm')
const str = `<surveyls_title><![CDATA[J.3200-1118 - Project Title]]></surveyls_title>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}