// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[CDATA\[(.*?)\]\]").unwrap();
let string = "<surveyls_title><![CDATA[J.3200-1118 - Project Title]]></surveyls_title>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}